Evolution Provider Issue

Incident Report for Betconstruct Status

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 15:00 GMT+04:00

Update

Please be informed that the issue concerns all Evolution child providers as well.
Posted Mar 04, 2025 - 13:09 GMT+04:00

Investigating

We are currently investigating this issue.
Posted Mar 04, 2025 - 12:20 GMT+04:00
This incident affected: 3rd Party Provider.