Casino Platform Issue
Incident Report for Betconstruct Status
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 08:58 GMT+04:00
Investigating
We are currently investigating this issue.
Posted Apr 17, 2024 - 07:03 GMT+04:00
This incident affected: Casino Bet Settlement, Casino Bets Placement, and Casino Report.