Backoffice Afterbalance Issue

Incident Report for Betconstruct Status

Resolved

This incident has been resolved.
Posted Oct 16, 2024 - 11:21 GMT+04:00

Investigating

We are currently investigating this issue.
Posted Oct 06, 2024 - 17:37 GMT+04:00
This incident affected: Betconstruct Back Office.