Issue with the Casino Section

Incident Report for Betconstruct Status

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 07:26 GMT+04:00

Investigating

We are currently investigating this issue.
Posted Mar 06, 2025 - 06:20 GMT+04:00
This incident affected: Casino Bet Settlement and Casino Bets Placement.