Issue with the Platform

Incident Report for Betconstruct Status

Resolved

This incident has been resolved.
Posted May 09, 2026 - 18:26 GMT+04:00

Investigating

We are currently investigating this issue.
Posted May 09, 2026 - 18:16 GMT+04:00
This incident affected: Betting Software Products (Casino Platform) and Payments System, Sport Bet Settlement, BackOffice Panel.