Backoffice replication issue
Incident Report for Betconstruct Status
Resolved
This incident has been resolved.
Posted Nov 09, 2024 - 15:28 GMT+04:00
Investigating
We are currently investigating this issue.
Posted Nov 09, 2024 - 15:14 GMT+04:00
This incident affected: BackOffice Panel.