Issue with the PG Soft Provider

Incident Report for Betconstruct Status

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 08:04 GMT+04:00

Investigating

We are currently investigating this issue.
Posted Mar 06, 2025 - 06:01 GMT+04:00
This incident affected: 3rd Party Provider.