Schedule maintenance : Play'n GO

Scheduled for May 26, 11:00 - 12:00 GMT+04:00

Update

We will be undergoing scheduled maintenance during this time.
Posted May 12, 2026 - 20:24 GMT+04:00

Scheduled

Start: 2026-05-26 11:00 GMT+4
End: 2026-05-26 12:00 GMT+4
Total Duration: 1h
Expected Impact: The services will be unavailable to customers during the timeframe below
We apologise for any inconvenience this may cause. We will post updates here as the maintenance progresses and when it is complete.
Posted May 12, 2026 - 20:20 GMT+04:00
This scheduled maintenance affects: 3rd Party Provider.