Partial issue with Evolution Provider Games
Incident Report for Betconstruct Status
Resolved
This incident has been resolved.
Posted Apr 05, 2023 - 09:29 GMT+04:00
Investigating
Kindly be informed that currently there is an issue with some of the games of the Evolution provider.
We apologize for any inconvenience it may cause while we try our best to resolve the issue as soon as possible.
Thank you for your patience and understanding.
Posted Mar 30, 2023 - 03:32 GMT+04:00
This incident affected: 3rd Party Provider.