Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 26, 2025 - 11:00 GMT+04:00
Scheduled
IMPORTANT: Schedule Maintenance / Slot Games / Red Tiger / 2025-06-26 / EU, LATAM, Africa, Asia / Game availability: affected
Dear Casino Team,
This is to inform you that the scheduled software upgrade will take place with downtime from 07:00 to 07:15 UTC on 26 June 2025. During this time, Red Tiger games may be unavailable.
You may find a summary below:
Start time: 26/Jun/25 7:00 UTC End time: 26/Jun/25 7:15 UTC Reason: Software upgrade Game availability: Affected Jurisdiction: EU, LATAM, Africa, Asia
Once the maintenance is completed, we will provide you with an update.
We apologize for the inconvenience.
If any questions arise, do not hesitate to contact us.
Posted Jun 25, 2025 - 10:47 GMT+04:00
This scheduled maintenance affected: 3rd Party Provider.