Global Issue with Casino/Live Casino
Incident Report for Betconstruct Status
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 03:14 GMT+04:00
Investigating
We are currently investigating this issue.
Posted Apr 12, 2024 - 02:44 GMT+04:00
This incident affected: Casino Bets Placement and Betconstruct/Creedroomz Live Casino.