Macaw Provider Maintenance

Scheduled for Nov 17, 11:00 - 14:00 GMT+04:00

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 14, 2025 - 15:52 GMT+04:00

Scheduled

Schedule maintenance:

Start: 17.11.2025 11:00 GMT+4
End: 17.11.2025 14:00 GMT+4
Total Duration: 3h

Expected Impact: The maintenance will be carried out to update the servers and equipment.
Due to this, games may not be available.
We apologize for any inconvenience this may cause. We will post updates here as the maintenance progresses and when it is complete.
Posted Nov 17, 2025 - 11:00 GMT+04:00
This scheduled maintenance affects: 3rd Party Provider.