Betconstruct Virtual Games Issue

Incident Report for Betconstruct Status

Resolved

This incident has been resolved.
Posted Feb 02, 2024 - 08:32 GMT+04:00

Investigating

We are currently investigating this issue.
Posted Feb 02, 2024 - 05:23 GMT+04:00
This incident affected: Betconstruct Virtual Sports.