Issue with Agent System
Incident Report for Betconstruct Status
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 17:07 GMT+04:00
Investigating
We are currently investigating this issue.
Posted Mar 27, 2024 - 15:38 GMT+04:00
This incident affected: Affiliates/Agents systems.