Issue with Casino Bonuses
Incident Report for Betconstruct Status
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 12:35 GMT+04:00
Investigating
We are currently investigating this issue.
Posted Jun 21, 2022 - 12:25 GMT+04:00
This incident affected: Bonuses.