Issue with CRM Cashbacks
Incident Report for Betconstruct Status
Resolved
This incident has been resolved.
Posted Jun 20, 2022 - 14:48 GMT+04:00
Investigating
We are currently investigating this issue.
Posted Jun 20, 2022 - 12:17 GMT+04:00
This incident affected: CRM.